Profile Picture

Using Password and Public Key authentication with SFTP

Posted By RS 2 Years Ago
Author
Message
RS
Posted 2 Years Ago
View Quick Profile
Forum Guru

Forum Guru (64 reputation)Forum Guru (64 reputation)Forum Guru (64 reputation)Forum Guru (64 reputation)Forum Guru (64 reputation)Forum Guru (64 reputation)Forum Guru (64 reputation)Forum Guru (64 reputation)Forum Guru (64 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 3, Visits: 3
I'm using Cute FTP Pro 8.3.

I've been able to use CuteFTP with SFTP sites using user-id/passwords, and am now trying to get it working with public/private key authentication.

The only way I'm able to get it working with public/private key authentication is by disabling "Use password authentication" within Global options, however if I do this, connectivity to existing sites using password authentication fails, with an immediate disconnect occurring.

If I leave "Use password authentication" and "Use public key authentication" enabled, connectivity to sites using Passwords works, but connectivity to sites using public key authentication fails.

How can I get CuteFTP to work with some SFTP sites using password authentication as well as to others using public/private key authentication? It seems to be an either/or approach.

vc02
Posted 2 Years Ago
View Quick Profile
Forum Guru

Forum Guru (61 reputation)Forum Guru (61 reputation)Forum Guru (61 reputation)Forum Guru (61 reputation)Forum Guru (61 reputation)Forum Guru (61 reputation)Forum Guru (61 reputation)Forum Guru (61 reputation)Forum Guru (61 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 2, Visits: 3
Sorry sorry sorry.
I don't have the answer unfortunately (I think there is no solution unfortunately because these options are global - maybe installing cuteftp pro twice but it is so weird) but as keys are working with your server, you can maybe help me here:
http://forums.globalscape.com/Topic31042.aspx?Keywords=Using%20Password%20%20Public%20%20authentication%20with%20SFTP
I've spent about 10 hours trying to fix this problem.
Thanking you in advance

RS
Posted 2 Years Ago
View Quick Profile
Forum Guru

Forum Guru (64 reputation)Forum Guru (64 reputation)Forum Guru (64 reputation)Forum Guru (64 reputation)Forum Guru (64 reputation)Forum Guru (64 reputation)Forum Guru (64 reputation)Forum Guru (64 reputation)Forum Guru (64 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 3, Visits: 3
Working with support, it was determined that even when using Public/Private key authentication, a password must be provided for a site. Once we did this, both methods of authentication worked successfully.


Edited 2 Years Ago by RS


Similar Topics


Reading This Topic