Home AWE

using MGET in AWE

JBrandonJBrandon Posts: 10 Resident

Has anyone been able to get MGET to work where it downloads a list of files. I know standard MGET in UNIX can use a "space" delimited list. I haven't been able to get it to work. Here is my basic AWE rule.







i'm setting my local folder with the 2nd line
changing remote directories with the 4th line
sending the passive command because I read active mode is default and that gives user prompts

I was able to get file using this setup but with a wildcard on the filename. example: filename*. however our real world case we have a list of varying filenames and a wildcard won't work.

Thanks
JB

Comments

  • JBrandonJBrandon Posts: 10 Resident

    Just saw that my AML code didn't take. bummer

  • JBrandonJBrandon Posts: 10 Resident

    here is my aml
    add a "<" to the front of every line for it to populate in your AWE

    AMVARIABLE NAME="remoteDir" VALUE="myremoteserverfolder" />

    AMFILESYSTEM ACTIVITY="change_folder" FOLDER="mylocalfolder" />

    AMFTP ACTIVITY="logon" SERVER="ftpserver.com" USERNAME="username" PASSWORD="password" TYPE="sftp" PORT="22" OVERWRITELOG="no" SESSION="FtpSession1" />

    AMFTP ACTIVITY="change_folder" FOLDER="/%remoteDir%" SESSION="FtpSession1" />

    AMFTP ACTIVITY="advanced" FTPCOMMAND="passive" SESSION="FtpSession1" />

    AMFTP ACTIVITY="advanced" FTPCOMMAND="mget" PARAMETER="filename1.txt filename2.txt" SESSION="FtpSession1" />

    AMFTP ACTIVITY="logoff" SESSION="FtpSession1" />

Sign In or Register to comment.